[lsb-discuss] Fate of libstdc++.so.7?

Wichmann, Mats D mats.d.wichmann at intel.com
Wed Apr 8 09:52:23 PDT 2009


Dallman, John wrote:
> Wichmann, Mats D [mailto:mats.d.wichmann at intel.com] wrote:
> 
>> Probably...  in any case it will appear as an additional
>> requirement that will not remove the need for a supported
>> version of libstdc++.so.6
> 
> That's because of the forwards compatibility undertakings, of
> course; LSB 3.x doesn't insist on an libstdc++.so.5, does it?


Until LSB 3.x there was not a requirement to support other LSB
versions as well; we certainly tried to make it easy for
a distro to support, say, LSB 2.0 and 3.x simultaneously,
and separate libstdc++ was part of that, but it wasn't
mandatory at the time, so nothing in 3.x or 4.0 requires
libstdc++.so.5, no.



More information about the lsb-discuss mailing list