[lsb-discuss] Minor queries on the LSB 4.0 SDK

Jeff Licquia jeff at licquia.org
Fri May 1 06:10:39 PDT 2009


Dallman, John wrote:
>>> Second, the lsbc++ and lsbcc compiler wrappers emit a warning every
>>> time they are run on SLES11:
>>>
>>>     Warning: gcc version "4.3" may have problems for LSB builds
>>>
>>> Is there actually a problem?
>> Yes, there are some.  I don't know if they're being worked on.
>> It's possible that we ought to change the warning so it only
>> emits if using lsbc++, I'm not aware of specific problems when
>> using lsbcc.  Jeff - what do you think?
> 
> Any comments, Jeff? We plan to use LSB 4.0 for building on SLES11,
> which is a GCC 4.3-based system. The need isn't urgent, as yet, 
> but it would help to know what the actual problems are.

There are a few.  We actually talked about them on the last LSB call, 
and have a rollup bug to keep track of them.  Here it is:

http://bugs.linuxbase.org/showdependencytree.cgi?id=2437&hide_resolved=1

I don't expect any of them will be difficult to fix.



More information about the lsb-discuss mailing list