[lsb-discuss] LSB Distribution Testkit Getting Started

Wichmann, Mats D mats.d.wichmann at intel.com
Fri Sep 18 22:46:29 PDT 2009

Bruce Dubbs wrote:
> Linux From Scratch is a book that documents how to build and install
> a GNU/Linux system from source code.  The project has been in
> continuous development for 
> about 10 years.
> Now, we would like to explain in the book how to make the
> installation that is built LSB complaint, but I need help in getting
> started.  The instructions on 
> the web site seem to assume that the user is already using a
> compliant distro. Documentation about trying to bootstrap into a
> compliant state is difficult to find. 

It's not totally simple to find, no.  The most important thing is
to get the right list of libraries, which can be obtained from a
number of places - including what's installed in /opt/lsb/lib (or lib64)
by the SDK.

> I first had to build rpm because that is not a part of our default
> installation. 
> I then downloaded and installed
> lsb-dist-testkit-4.0.0-4.x86_64.tar.gz. 
> When starting, LSB failed because there is no lsb_release program.  I
> could not find a reference implementation for this so I hacked a
> debian version so that I get: 

There is a reference version but I'll need to hunt around a bit
to see where we're keeping the tarball these days.  The version control
form is http://bzr.linuxfoundation.org/lsb/devel/si  (lsb_release
subdirectory of that branch)

> $ lsb_release -a
> LSB Version:    core-4.0-x86_64:core-4.0-noarch
> Distributor ID: LFS
> Description:    Linux From Scratch
> Release:        6.5
> Codename:       6.5
> I also tried using an LSB Version of core-4.0-amd64.
> .
> I then had to create a symlink ld-lsb-x86-64.so.3 ->
> ld-linux-x86-64.so.2. 

One of the somewhat more obscure requirements... sorry :)

> When I run ./lsb-tef.pl core, the tests now seem to start but then I
> get: 
> ...
> LC_ALL=C passwd vsx0
> ...
> passwd: password changed.
> root at core2:/opt/lsb/test/core/tet/test_sets# [23:46:50] Subshell
> output stalled 
> for 60 seconds
> and then after about 10 minutes and additional stalled messages, the
> whole test fails.
> I've searched the FAQ, google, and the LSB website, but can't figure
> out where 
> to go from here.  There may be some packages or other prerequisites
> that I'm missing, but I can't figure out what they would be.  I'd
> appreciate any pointers about how to proceed.

Some tests do "stall" - or rather have various timeouts in them
so that they run slowly, which gives the same message, so *some* of
that is expected, but obviously not just quitting.

It's late right now but we'll send you some more pointers.

More information about the lsb-discuss mailing list