[lsb-discuss] produce lsb compatible binary(bootloader)

Prashant Saxena animator333 at yahoo.com
Wed Apr 7 23:57:55 PDT 2010


Thanks Wichmann,

It worked!!!!

I owe you a "Fucking Hell"
Fucking Hell = http://www.spiegel.de/international/zeitgeist/0,1518,686305,00.html

LSB compatible bootloader is out. By default it supports 23 distributions out of 36. There are two interfaced used in the code which are LAC incompatible.

fork & wait
library : libpthread.so.0

and the small piece of code where they are used:
pid = fork();
        if (pid == 0)
            execvp(thisfile, argv);
        wait(&rc);
        rc = WEXITSTATUS(rc);

Could you please guide me how to replace them to make the binary more lsb compatible?

Cheers

Prashant



      Your Mail works best with the New Yahoo Optimized IE8. Get it NOW! http://downloads.yahoo.com/in/internetexplorer/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.linux-foundation.org/pipermail/lsb-discuss/attachments/20100408/e12bc26c/attachment.htm 


More information about the lsb-discuss mailing list