[lsb-discuss] produce lsb compatible binary(bootloader)

Prashant Saxena animator333 at yahoo.com
Sun Apr 11 21:16:09 PDT 2010


Ok,

I did the most important test to run the app on a lower 
version. Binary was compiled on karmic 9.10 using LSBCC_BESTEFFORT=1 
option and but it didn't execute on a freshly installed ubuntu 8.04.4 
LTS.

The error is:
/lib/tls/i686/cmov/libc.so.6: version 
`GLIBC_2.9' not found (required by 
/home/prashant/installed/dist-gtk/libgio-2.0.so.0

I was expecting this , the package was compiled on karmic 9.10 and libgio-2.0.so.0 is coming from 9.10.
On ubuntu LTS 8.04.4 glibc version is compatible with it.

It seems bootloader is working fine and main app is getting executed.

I think I am back to square one, there is huge list if libraries that is getting packed along with the app and they would be needing glibc 2.9 or higher.
The only solution I can think of right now is to use ubuntu 8.04.4 LTS to deploy the app and do rest of the stuff.

Prashant

Send free SMS to your Friends on Mobile from your Yahoo! Messenger. Download Now! http://messenger.yahoo.com/download.php
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.linux-foundation.org/pipermail/lsb-discuss/attachments/20100412/9052add5/attachment.htm 


More information about the lsb-discuss mailing list