[lsb-discuss] produce lsb compatible binary(bootloader)

Stew Benedict stewb at linux-foundation.org
Mon Apr 12 04:06:43 PDT 2010

Prashant Saxena wrote:
> Ok,
> I did the most important test to run the app on a lower version.
> Binary was compiled on karmic 9.10 using LSBCC_BESTEFFORT=1 option and
> but it didn't execute on a freshly installed ubuntu 8.04.4 LTS.
> The error is:
> /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.9' not found (required
> by /home/prashant/installed/dist-gtk/libgio-2.0.so.0
> I was expecting this , the package was compiled on karmic 9.10 and
> libgio-2.0.so.0 is coming from 9.10.
> On ubuntu LTS 8.04.4 glibc version is compatible with it.
> It seems bootloader is working fine and main app is getting executed.
> I think I am back to square one, there is huge list if libraries that
> is getting packed along with the app and they would be needing glibc
> 2.9 or higher.
> The only solution I can think of right now is to use ubuntu 8.04.4 LTS
> to deploy the app and do rest of the stuff.
> Prashant
I'm confused. Are you still compiling with lsbcc? Where does
/home/prashant/installed/dist-gtk/libgio-2.0.so.0 come from? You just
grabbed a distro copy of the library? You would need to compile this
with lsbcc also, or as you mention, build on and use libraries from the
oldest system possible. This is what I've heard many ISVs do. Are you
actually using libgio, or it's just showing up as a dep to another
library (LSB doesn't include it, but we're usually able to still build
things without it),

Stew Benedict
Linux Foundation

More information about the lsb-discuss mailing list