[lsb-discuss] Query on recent 4.0 certifications

Craig Scott craig.scott at csiro.au
Tue Dec 28 14:31:27 PST 2010


On Wed, 29 Dec 2010 12:11:05 am Stew Benedict wrote:
> On 12/28/2010 01:04 AM, Craig Scott wrote:
> > Hi all. Recently, I saw an announcement that various major linux distributions are now certified for LSB 4.0, which is great. Included in that list was "SUSE Linux Enterprise 11". I thought it was time to check again how many things break if I compiled the latest Qt source with the LSB implementation provided on a SLED 11 machine (note, it was actually SLED11 with sevice pack 1). I discovered that the following bug is still present in the SLED11 LSB implementation:
> >
> > http://bugs.linuxbase.org/show_bug.cgi?id=2521
> >
> > Given that the above bug was closed almost 2 years ago, this would seem to suggest one or more of the following:
> >
> > (a) The LSB 4.0 certification tests didn't pick up the regression
> > (b) The LSB 4.0 certification didn't require the bug to be fixed (which would seem odd)
> > (c) The regression was re-introduced by the SLED 11 service pack (assuming SLED 11 without service packs doesn't also show the regression - I cannot test this, sorry).
> > (d) The SUSE packages are simply using the LSB packages provided by the linux foundation, but SUSE didn't grab recent enough packages and therefore have not picked up the fix
> >
> > My main interest here is working out where the breakdown was and who should be fixing what. Ultimately, I'm trying to get to a working LSB-compliant Qt build that we can include in our own packages. The Qt version that the LSB covers isn't recent enough for us, so we need to be able to provide an updated set of Qt libraries, headers, etc with our own RPM's. We also need to understand if other developers would encounter the same problems and on which linux distributions.
> >
> > Any insights people can offer would be welcome.
> >
> > Cheers.
> >
> >   
> I'm not sure what you're using here for the compilation. An LSB SDK
> provided by SLED11 or one provided by the LSB workgroup?
> If I look at the X11/Xutil.h header here, the referenced bug would
> appear to be fixed. The tests would definitely not pick up a header
> issue on the target system, they look at binary compatibility. This bug
> was against the SDK provided by the LSB. I'm not sure what SLED11 might
> be shipping in terms of an LSB SDK.


Hmmmm.... after your question I took a closer look at the yast repositories that were set up for the SLED 11 machine I was using for testing. It looks like the lsb-buildenv package came from the SLE11 SDK DVD. Is this covered by the LSB 4.0 certification? 

-- 
Dr Craig Scott
Computational Software Engineering Team Leader, CSIRO (CMIS)
Melbourne, Australia


More information about the lsb-discuss mailing list