[lsb-discuss] LSB 4.1: Apache Tests(2.2.14-8) Failed to prepare apache

ashish yadav ashishyadav78 at gmail.com
Thu May 1 05:26:21 UTC 2014


Hi,

After doing some debugging, I found  rpm failed due to:
%post
/usr/lib/lsb/install_initd /etc/init.d/lsb-apache

Above command is failing due to:
1. /lib/lsb/init-functions (this file is missing in my Machine).
  After making soft link to this

#ls -al /lib/lsb/init-functions
lrwxrwxrwx 1 root root 36 Apr 30 13:22 /lib/lsb/init-functions ->
/etc/init.d/functions.lsbinitscripts

  This command still fails, may be due to more dependencies.

Could you please let me know what more packages needed for this test ?


Thanks



On Wed, Apr 30, 2014 at 6:17 PM, Mats Wichmann <mats at wichmann.us> wrote:

> Sorry,  dont have real kbd today!
>
> Src is  apache tarball of same vers + appbat branch at
> Bzr.linuxfoundation.org/4.1/appbat for patches & build recipe
>
>
> On 30 April 2014 06:33:36 MDT, ashish yadav <ashishyadav78 at gmail.com>
> wrote:
> >Hi,
> >
> >Could you please share the link from where I can get
> >lsb-apache-2.2.14-8.lsb4.x86_64.rpm source code ?
>
> >>
> >> On Tue, Apr 29, 2014 at 10:21 AM, ashish yadav
> ><ashishyadav78 at gmail.com>wrote:
> >>
> >>> Hi,
> >>>
> >>> While running Apache Tests, Get following Message:
> >>>
> >>> Warning:
> >>>
> >>>     Failed to prepare apache. The test will be skipped
> >>>         Failed to download and install packages for 'apache' test.
> >>>             Failed to install 'lsb-apache' v. '2.2.14-8.lsb4'
> >package required
> >>> by apache test.
> >>>                 Installer's output:
> >>>                 %> rpm -i
> >>>
> >'/var/opt/lsb/test/manager/packages/
> ftp.linuxfoundation.org/pub/lsb/app-battery/released-4.1/amd64/lsb-apache-2.2.14-8.lsb4.x86_64.rpm
> '
> >>>                 warning:
> >>>
> >/var/opt/lsb/test/manager/packages/
> ftp.linuxfoundation.org/pub/lsb/app-battery/released-4.1/amd64/lsb-apache-2.2.14-8.lsb4.x86_64.rpm
> :
> >>> Header V4 DSA signature: NOKEY, key ID bdc76b46
> >>>                 error: %post(lsb-apache-2.2.14-8.lsb4.x86_64)
> >scriptlet failed,
> >>> exit status 1
> >>>                 warning: u 0x64c300 ctrl 0x624b30 nrefs != 0
> >>> (pool.sks-keyservers.net hkp)
> >>>                 warning: pool fd: FIXME: made 4, count 3
> >>>                 Note: This is a harmless memory leak discovered
> >while exiting,
> >>> relax ...
> >>>
> >>>
> >>>
> >>> Following is Setup Info:
> >>> 1.root at x86-generic-64:~# uname -a
> >>> Linux x86-generic-64 3.10.20.x86-generic-64-rt14 #1 SMP PREEMPT Thu
> >Apr 24
> >>> 19:05:29 IST 2014 x86_64 GNU/Linux
> >>>
> >>>
> >>> 2. LSB Version 4.1
> >>>
> >>>
> >>> Please let me know if I need to install any other package for this
> >test ?
> >>>
> >>> Thanks & Regards
> >>>      Ashish
> >>>
> >>>
> >>>
> >>
> >
> >
> >------------------------------------------------------------------------
> >
> >_______________________________________________
> >lsb-discuss mailing list
> >lsb-discuss at lists.linux-foundation.org
> >https://lists.linuxfoundation.org/mailman/listinfo/lsb-discuss
>
> --
> Sent from my Android device with K-9 Mail. Please excuse my brevity.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfoundation.org/pipermail/lsb-discuss/attachments/20140501/a24c0ba8/attachment.html>


More information about the lsb-discuss mailing list